Using playit agent on docker


I’m using your agent on a Docker and I’ve managed to connect successfully to my Minecraft server.
However, from security reason, I want to keep my servers inside internal Docker network and not to expose them to Host ports.

This raise me a problem when I’ve created the Tunnel - so instead of using address - I need to use the internal Docker IP of the Minecraft server - which is constantly changing.
I tried to enter a host name - but got an “application error”.

Can you please enable host-name as an input for the tunnel and not just an IP ?


I defined the networks in compose.yaml, set a static IP address for each service, and then set the IP address in playitgg web.