[Solved] Ethernet driver Problems with playit and modded mc-server


it turned out to have nothing to do with playit. It was a problem with my Ethernet chip (Intel 1225-V Network driver chip)

here are some useful links and potential fixes

so i have been using playit for a while now, but recently i have been experiencing some issues with my ethernet (i think more specifically my ethernet driver) (also im on Win10)

I actually dont think it has anything to do with playit, but i just saw another person have the same problem in the discord when using playit. and i have only experienced this when having playit running

So basically what happens:

  • i run a mc server and playit

  • after a few hours (anywhere from 2-8 hours) my ethernet breaks, this only seems to happen if people are connected to the server (or shortly after someone connects)

  • ethernet just stops working, the PC shows “no connection” under ethernet

  • the only way to fix this is to restart the PC (sometimes resulting in a bluescreen with Error: DRIVER_POWER_STATE_FAILURE (so probably the ethernet driver crashed or something)

so as i already said, im not sure if playit is actually causing this, but it only seemed to happen while i was using it. been having this problem for a week or so now (already updated drivers and windows).