Minecraft Bedrock server refuses to load for users on a cellular connection

Hello everyone, I run a bedrock Minecraft server for me and acouple mates, and while Playit.gg has worked great so far there is one small issue that I’ve noticed. The bedrock server doesn’t want to connect when the user is using a cellular connection instead of a fixed broadband connection. I have confirmed this myself by trying to connect on my phone using a 4G connection and can confirm it doesn’t load. Most of the users of the server do have a fixed broadband connection (including myself using starlink) but there are a select few who do rely on a mobile connection to play online, and plus it would be nice to access the server while out and about at school or work. If someone could please tell me a work around for this issue, or just let me know if its a limitation with playit.gg or mobile providers that would be great. Thank you!

1 Like

I’m having a similar issue, my java server works fine on cell hotspot but my bedrock (I’m using geyser) tells me “unable to connect to world”. I’m trying to see if my bedrock server doesn’t work outside of my home wifi or if it’s just cell. I’ve been told to use instead of my public IP, but that makes no difference on my end. Also, the geyser wiki troubleshooting page says that if the port is less than 10000 that will also give you issues, I’ve been assigned 1690 from Playit and if that’s what’s causing my issue Playit won’t let me change my Allocation (Shared IP). If your shared IP port is less than 10000 let me know because I suspect that’s the issue.