"Failed to connect to tunnel" Error on Startup

I’m currently using Playit 0.9.3 on Ubuntu 22.04. In the past, Playit worked fine without any hitches, however, it has suddenly started to fail each time I try to run it; Playit says: "Preparing connection to “control.playit.gg”, then says: “Status: failed to connect to tunnel”. I have tried reinstalling it and deleting playit.toml with no success.

When I reconnect it to my account following the reinstall, the connection shows up in my list of agents in the account page, but it still fails to connect to the tunnel shortly after the startup.

Try updating DNS, worked for me:
Windows : Update your DNS server on Windows | playit.gg - support pages
MacOS : Update your DNS server on MacOS | playit.gg - support pages
faq on discord

We were having some DNS issues that should now be resolved. In the past updating your DNS server to Cloudflare or Google would more often than not fix the issue (but not always). This should be fixed now.

I’m getting the same error again. “Failed to connect to tunnel”

Edit: restarting the PC somehow worked