Agent is unable to connect to tunnel

When I try to run the agent (0.9.3) it says “Status: failed to connect to tunnel,” then it just closes. I’ve tried deleting playit.toml, redownloading the agent, and updating my dns, but I still get the error.

2 Likes

Same Problem how to solve please help me

I am having the same issue. Linux container running inside of Proxmox.Things where working fine for months, now stopped. I removed the config and allowed the agent to reconfigure itself like the OP to no avail. I’ve resent DNS. I’ve deleted all agents from the website UI, and reconfigured.

Logs

2022-12-03T16:45:46.928322Z INFO agent: starting without trying UI
2022-12-03T16:45:46.928614Z INFO agent: starting playit agent, version: 0.9.3 settings=StartSettings { config_file_path: “/etc/playit/playit.toml”, try_ui: false }
2022-12-03T16:45:47.930755Z INFO agent: loading msg=account verified
2022-12-03T16:45:47.931154Z INFO agent: loading msg=loading latest configuration
2022-12-03T16:45:48.239015Z INFO agent: loading msg=preparing connection to “control.ply.gg”
2022-12-03T16:45:49.355500Z ERROR get_working_io{address=“control.ply.gg” option=[::]:5523}: playit_agent_core::control_lookup: timeout waiting for pong response
2022-12-03T16:45:50.360219Z ERROR get_working_io{address=“control.ply.gg” option=[::]:5523}: playit_agent_core::control_lookup: timeout waiting for pong response
2022-12-03T16:45:51.364073Z ERROR get_working_io{address=“control.ply.gg” option=[::]:5523}: playit_agent_core::control_lookup: timeout waiting for pong response
2022-12-03T16:45:51.365085Z WARN get_working_io{address=“control.ply.gg” option=[::]:5523}: playit_agent_core::control_lookup: failed to connect
2022-12-03T16:45:52.370036Z ERROR get_working_io{address=“control.ply.gg” option=0.0.0.0:5523}: playit_agent_core::control_lookup: timeout waiting for pong response
2022-12-03T16:45:53.375417Z ERROR get_working_io{address=“control.ply.gg” option=0.0.0.0:5523}: playit_agent_core::control_lookup: timeout waiting for pong response
2022-12-03T16:45:54.380828Z ERROR get_working_io{address=“control.ply.gg” option=0.0.0.0:5523}: playit_agent_core::control_lookup: timeout waiting for pong response
2022-12-03T16:45:54.382195Z WARN get_working_io{address=“control.ply.gg” option=0.0.0.0:5523}: playit_agent_core::control_lookup: failed to connect
2022-12-03T16:45:54.383313Z INFO agent: loading msg=failed to connect to tunnel

The most resent configuration file generated differently than what was previously in place. It’s now a very terse

refresh_from_api = true
secret_key = ‘’
mappings = []

Resolved by following Update your DNS server on Linux | playit.gg - support pages

My cloudflare family protected DNS must have picked up a squelch on playitt.gg
No longer looking at this DNS resolved the issue.

Same thing just started for me, tunnel won’t connect.

Whitelisting *.ply.gg on my DNS filter fixed the problem.

My Optimum router uses automatic dns and I dont think it has a filter. Any advice?

You could be using a DNS server that filters though. In my case I use NextDNS so I had to add to their allow list. There are many others that do the same such as OpenDNS, etc. also this can happen if you use something local such as piHole.

I’m having this problem as well. The program will attempt to add a new agent any time I delete the toml file / remove the previous agent, but it gets stuck after prompting me on the website. It seems like the program can communicate to the website but the website can’t communicate back ? Another weird thing is that the agent it creates in the list is completely blank.

This straight up just does not work for me lol not resolved

My router was blocking ply.gg. Problem is now fixed! :slight_smile:

Yeah, I’m currently reaching out to ISPs to try and get us unblocked. It’s really annoying.